Oracle 11g 의 JDBC 드라이버는 JSE 5.0 이후부터 사용 가능 Programmer's notes

Oracle 11g 의 JDBC 드라이버는 현재 11.1.0.6.0 버전까지 나와있습니다.
뭐 좋아진 것이 있나 해서 Readme.txt 를 봤더니 JSE 6.0 과 JDBC 4.0 을 지원한다고 나오는군요.
그런데 J2SE 1.4 와 그 이전의 JVM 에서는 사용할 수가 없다네요.
아직 프로젝트에서 웹로직 6.1 과 J2SE 1.3 을 사용하기에 그렇게 하는 오라클에 좀 서운한 감정이 있지만 어짜피 JDBC 4.0 의 기능을 쓸 수 없으니 아쉬울 것은 없습니다.
그나저나 이제는 JSE 5.0 도 좀 써보고  6.0 에도 관심을 주어야 해야할텐데 하고 있는 프로젝트가 너무 기네요 ㅋ

아무튼 J2SE 1.4 이전의 환경에서는 11g 에 포함된 JDBC를 쓸 수는 없지만 오라클 11g 를 사용한다면 10.2.X 버전의 JDBC 드라이버를 쓰면 문제없다고는 합니다.

덧글

댓글 입력 영역